Image of the day

From the
ATWB Customer Gallery

M31 Andromeda Galaxy

My Account

New to Astromart?

Register an account...

Need Help?

C14 Does not Focus

Started by Mike Francioli, 07/15/2014 09:58AM
Posted 07/15/2014 09:58AM Opening Post
I purchased a Celestron C14 on Astromart about a year and a half ago. It is the newer black tube design with air vents, non-HD Edge and non-Fastar. It arrived perfectly packed, with no damage. I stored it until recently after putting up my observatory, and using it for the first time last night. To my shock, it won't focus. Locked on a star, it produces a large, faint, Airy disk (with no diffraction rings)and central obstruction. Could not focus the image any better as it seems I've run out of threads in the focusing rod, or the mirror assembly gets caught at a certain point. Anybody experience this, or have any ideas?

Thanks for the help! Mike
Posted 07/15/2014 11:23AM #1
Mike, make certain the mirror is not locked, as it should have been for shipping. A C14 should focus anything you're likely to put in it. Don't try to force the focuser without making certain the lock is released.

George
Posted 07/16/2014 03:31AM #2
Look inside the tube to see if any rear cell accessory screws are protruding too far in and hitting the primary mirror.

Mike Francioli said:

I purchased a Celestron C14 on Astromart about a year and a half ago. It is the newer black tube design with air vents, non-HD Edge and non-Fastar. It arrived perfectly packed, with no damage. I stored it until recently after putting up my observatory, and using it for the first time last night. To my shock, it won't focus. Locked on a star, it produces a large, faint, Airy disk (with no diffraction rings)and central obstruction. Could not focus the image any better as it seems I've run out of threads in the focusing rod, or the mirror assembly gets caught at a certain point. Anybody experience this, or have any ideas?

Thanks for the help! Mike